After 24 hours of monitoring, we have seen no network blocks to our mobile application endpoints. Our service is behaving as expected at this time.
Posted Feb 18, 2026 - 14:41 EST
Monitoring
We wanted to provide an update regarding the recent mobile login issues, particularly impacting some users on certain mobile networks.
During our review, we identified that increased login activity from shared mobile network connections was triggering protective safeguards within our security infrastructure. These safeguards are in place to protect our platform and client data; however, under certain network conditions, they were unintentionally affecting legitimate user access.
We have implemented configuration adjustments that have been successfully tested and are designed to significantly reduce customer impact while maintaining the integrity and security of our systems.
In addition, we are enhancing our monitoring capabilities to proactively detect and address similar patterns should platform usage levels or network behaviors change in the future.
If you continue to have specific users experiencing login timeouts, please share their usernames, mobile carrier (if known), and approximate time of occurrence so we can investigate further.
We appreciate your patience while we worked through this and remain committed to ensuring a secure and reliable experience for your teams
Posted Feb 17, 2026 - 13:29 EST
This incident affected: Mobile Android Application and Mobile iOS Application.